安装hexo是node-gyp安装失败啥情况?
发布于 10小时前 作者 elevensky 32 次浏览 来自 问答

系统版本:os x 10.9.4

fsevents@0.2.0 install /usr/local/lib/node_modules/hexo/node_modules/chokidar/node_modules/fsevents node-gyp rebuild

gyp WARN install got an error, rolling back install gyp ERR! configure error gyp ERR! stack Error: Connection closed while downloading tarball file gyp ERR! stack at Request.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/install.js:236:14) gyp ERR! stack at Request.emit (events.js:117:20) gyp ERR! stack at IncomingMessage.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/request/request.js:846:44) gyp ERR! stack at IncomingMessage.emit (events.js:117:20) gyp ERR! stack at IncomingMessage.<anonymous> (http.js:1515:11) gyp ERR! stack at IncomingMessage.emit (events.js:117:20) gyp ERR! stack at _stream_readable.js:938:16 gyp ERR! stack at process._tickCallback (node.js:419:13) gyp ERR! System Darwin 13.3.0 gyp ERR! command “node” “/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” “rebuild” gyp ERR! cwd /usr/local/lib/node_modules/hexo/node_modules/chokidar/node_modules/fsevents gyp ERR! node -v v0.10.30 gyp ERR! node-gyp -v v0.13.1 gyp ERR! not ok npm WARN optional dep failed, continuing fsevents@0.2.0 /usr/local/bin/hexo -> /usr/local/lib/node_modules/hexo/bin/hexo hexo@2.8.3 /usr/local/lib/node_modules/hexo ├── strip-indent@0.1.3 ├── hexo-front-matter@0.0.4 ├── sprintf-js@0.0.7 ├── colors@0.6.2 ├── graceful-fs@3.0.5 ├── mime@1.3.4 ├── minimist@0.2.0 ├── async@0.9.0 ├── warehouse@0.2.2 (async@0.7.0) ├── highlight.js@8.1.0 ├── lodash@2.4.1 ├── moment@2.9.0 ├── compression@1.4.0 (vary@1.0.0, bytes@1.0.0, on-headers@1.0.0, debug@2.1.1, compressible@2.0.2, accepts@1.2.3) ├── morgan@1.5.1 (basic-auth@1.0.0, depd@1.0.0, debug@2.1.1, on-finished@2.2.0) ├── js-yaml@3.2.6 (esprima@1.0.4, argparse@0.1.16) ├── connect@3.3.4 (utils-merge@1.0.0, parseurl@1.3.0, debug@2.1.1, finalhandler@0.3.3) ├── serve-static@1.8.1 (utils-merge@1.0.0, escape-html@1.0.1, parseurl@1.3.0, send@0.11.1) ├── swig@1.4.1 (optimist@0.6.1, uglify-js@2.4.16) ├── cheerio@0.17.0 (entities@1.1.1, dom-serializer@0.0.1, CSSselect@0.4.1, htmlparser2@3.7.3) └── chokidar@0.8.2 (recursive-readdir@0.0.2) 求指导啊

回到顶部