关于mongoose aggregate的问题。请教各位大神!!!
发布于 2个月前 作者 moJiXiang 534 次浏览 来自 问答

本地mongodb版本为2.6.4,线上mongodb版本为2.2.2。mongoose都为最新版本。

本地测试aggregate的$geoNear操作管道可以通过,但是线上没有通过,提示错误如下

{ [MongoError: Pipeline::run(): unrecognized pipeline op "$geoNear]
  name: 'MongoError',
  errmsg: 'Pipeline::run(): unrecognized pipeline op "$geoNear',
  ok: 0 }

是否mongodb版本的问题,如果是,能否轻易的升级版本呢,会有其他问题发生吗?请教,谢谢!

3 回复

我一直以为$geoNear这个管道是最垃圾的,没想到还真有人用。。我估计你那是版本问题。升级版本这个还是看官方文档 吧。

另:请教楼主,我现在遇到一个问题。我有一个集合里有一个ref字段关联另一个集合,一般情况下,我用populate可以关联查询出来。 但是我现在还需要用aggregate来分组统计计算一下。。可是却不支持ref字段?怎么办呢?

@winky 为什么垃圾啊,求解,我觉得效率挺高的啊,对于简单的距离排序,用起来方便。

回到顶部