nodejs怎么降级成0.8.x
发布于 7个月前 作者 yakczh 905 次浏览

npm WARN engine cryptiles@0.1.3: wanted: {"node":"0.8.x"} (current: {"node":"v0.10.7","npm":"1.2.21"}) npm WARN engine sntp@0.1.4: wanted: {"node":"0.8.x"} (current: {"node":"v0.10.7","npm":"1.2.21"}) npm WARN engine boom@0.3.8: wanted: {"node":"0.8.x"} (current: {"node":"v0.10.7","npm":"1.2.21"}) npm WARN engine hoek@0.7.6: wanted: {"node":"0.8.x"} (current: {"node":"v0.10.7","npm":"1.2.21"}) npm http GET http://registry.npmjs.org/delayed-stream/0.0.5 npm http GET http://registry.npmjs.org/delayed-stream/0.0.5 npm ERR! npm ERR! Additional logging details can be found in: npm ERR! npm-debug.log npm ERR! not ok code 0

有办法吗?

6 回复
$ npm install -g n
$ n 0.8.17

详细使用说明看这里:https://www.npmjs.org/package/n

nvm 控制node版本是个好办法

npm ERR! notsup Unsupported npm ERR! notsup Not compatible with your operating system or architecture: n@1.2.9

不是包的版本,是node本身版本么?

回到顶部